XWatermark

Discussion of the xtools Toolkit

Moderators:xbytor, DavideBarranca, Paul MR

Post Reply
xbytor
XWatermark

Post by xbytor » Tue Sep 09, 2008 11:00 pm

Here's an update. It's just about done.

It's pretty easy to use. However, you can embed metadata into text watermarks. The syntax for doing this is the PDF file.

-X

Yaz

XWatermark

Post by Yaz » Thu Mar 05, 2009 5:20 pm

I created all my logo actions based on location (Bottom-left, Top-right etc) and when I finally got done and was looking for a way to build a menu, I found XWatermark! Arrgh. What's worse is that I already installed xtools earlier for the ActionToJavascript. OK, so I love it, and am kicking myself for not seeing it sooner. Enough venting.

What I need to know is if there is a way to batch process using this action/script. I have a set of images that I want to use the same settings for and don't want to enter them each time....

I'm sorry if this is a 'duh' easy-answer question, but I'm really new to Photoshop. If you point me in the right direction, I'll try and figure it out.

Thanks,


Yaz

xbytor

XWatermark

Post by xbytor » Thu Mar 05, 2009 5:34 pm

What I need to know is if there is a way to batch process using this action/script. I have a set of images that I want to use the same settings for and don't want to enter them each time....

Record an action adding a watermark in a script. Turn of the Dialog check box for that action step. Batch the action.

It that doesn't work, let me know and I'll fix it.

-X

Yaz

XWatermark

Post by Yaz » Thu Mar 05, 2009 6:08 pm

Thanks for the super fast response!

So I tried what you said and was prompted with settings dialog for each image. It remembered the settings though, which is good.

Here are the steps I did, in case I did something wrong...

1. Created new action and clicked Record
2. Played Watermark script & entered desired settings
3. Clicked "Stop Recording"
4. Tested this new action and it works fine.
5. Made sure Dialog is toggled off for the action and the script step.
6. Ran batch with "suppress file open options dialog" checked.

Thanks Xbytor!

-Yaz

xbytor

XWatermark

Post by xbytor » Thu Mar 05, 2009 6:21 pm

Yaz wrote:1. Created new action and clicked Record
2. Played Watermark script & entered desired settings


Did you press the 'OK' button at this point? It won't record the settings if you don't.

3. Clicked "Stop Recording"
4. Tested this new action and it works fine.
5. Made sure Dialog is toggled off for the action and the script step.
6. Ran batch with "suppress file open options dialog" checked.


My copy appears to be working fine. Send me the version you have. There may be differences between the two.

-X

Yaz

XWatermark

Post by Yaz » Thu Mar 05, 2009 6:34 pm

Yes, I did click OK, so it remembered the settings. However, the dialog kept prompting (with remembered settings).

Attached is the version I have (from the 1.6 release on this forum).

Rename the file (remove .zip) as it's actually the jsx file not really zipped.

Yaz

XWatermark

Post by Yaz » Thu Mar 05, 2009 6:52 pm

I noticed there are two separate files for xwatermark.jsx - one is in the apps folder, and the other is in the xapps folder. I noticed a size difference between the two 6K vs 449K. I tried with the other one as well, and same results. I keep getting prompted when i run it in batch mode (clicking the recorded action works fine). I've attached the 449K sized one to this post. Again, don't try to extract, since it's not really zipped. Just rename the file and remove the .zip extension.

Thanks!

xbytor

XWatermark

Post by xbytor » Fri Mar 06, 2009 6:23 pm

Here's is a current rev of the /apps/ version. Those in that folder are stand-alone and, as such, can be run on any PS machine whether or not xtools has been installed.

Try this and let me know if it works any better. If not, I'll take a closer look.

-X

Post Reply