Random ActionManager error

Discussion of actual or possible Photoshop Scripting Bugs, Anomalies and Documentation Errors

Moderators: Tom, Kukurykus


Random ActionManager error

Post by undavide »

sorry to crosspost here too, but I'm bumping into severe troubles with ESTK and scripts involving ActionManager code.
The debugger halts randomly at lines like:

Code: Select allvar d = new ActionDescriptor();

with "Error: ActionDescriptor" and there's no way to go ahead. I had to restart PS (which is of course the target in ESTK) to complete the very same script error-free, yet it seems the situation is deteriorating and it's impossible to work.
Corrupted preferences? I've reset PS prefs, disk permission (Mountain Lion) are ok, rebooted the OS, tried with another brand new Admin user. Could be the many ESTK versions installed (4, from CS3 to CS6) interfering?
I've also tried to run the scripts in PS CS5, no way. I mean, even this script hangs:

Code: Select all#target photoshop
var d = new ActionDescriptor();

Any help is appreciated!